4 Reasons Not to Install iOS 10.2 & 6 Reasons You Should

Advertisement

Don't Install iOS 10.2 If You're Jailbroken

9 / 10
Don't Install iOS 10.2 If You're Jailbroken
Advertisement

Avoid iOS 10.2 if you're jailbroken or you want to jailbreak your iPhone, iPad or iPod touch.

Developers have released an iOS 10 jailbreak beta for select devices running iOS 10.1.1 and iOS 10.1 but nothing is available for iOS 10.2. So, if you move to iOS 10.2, you'll lose your current jailbreak and/or lose the ability to jailbreak your phone or tablet. 

As of right now, the only way to jailbreak your iPhone or iPad without using an unstable beta is with a compatible device running iOS 9.3.3 or older. If you're on anything newer than that, and again that includes the iOS 10.2 update, you're out of luck.

We still don't have any details about an official iOS 10 jailbreak release and it could be days, weeks or even months before something lands for the general public.

9 / 10
Advertisement