iTunes and ReadyBoost Don’t Play Well Together

ItunesvistaWell, well, well. We’ve know for some time that Apple’s iTunes and Microsoft Vista have had some problems. Version 7.1 was supposed to have taken care of most of them, (although Vista users are still encouraged to disconnect their iPod from inside of iTunes and not through the Safely Disconnect command from the Task Tray.) But this problem popped up for me last night and lo and behold a solution, (well kinda, sorta) offered itself up this morning thanks to Omar Shahine.

The guys at jkOnTheRun released another Mobile Edition review over the weekend, this time taking a look at several WaterField cases and I thought I’d take a look.(Note to wife: No, I’m not thinking of gettting another bag, really. Thanks, Rob.)  I decided to download it via iTunes and was extremely disappointed that the playback was just awful. (No fault of jk, I figured it had something to do with my system.) It herked and jerked along, making it unwatchable.


Today, cruising my feeds I saw an interesting item from the aforementioned Omar Shahine pointing me to Vista.Blorge, a site that describes how iTunes and Vista’s ReadyBoost don’t play well with each other. Sure enough after removing the SD card I’m using for ReadyBoost, I was able to watch the video with no issues via iTunes. I’ve replicated this at least several times now on both the Lenovo X60 and the Asus R2H. I don’t see the issue that the author Jonathon Schlaffer has with music playback in iTunes, only with video, but I’m guessing this is has to do with the still relatively confusing ReadyBoost voodoo and the devices you choose to run it.