When Mobility devices do not work right …Grrrrrrrr

image It was to be a great long weekend out of town.  My sister and I had been planning a big event to celebrate my parents 50th wedding anniversary.  We had a great event with lots of great friends and family, and the folks truly enjoyed their time.  I used my Lenovo X61 and a portable DLP projector to project 50 years of memories on a wall at the venue while playing 50’s music with my Zune plugged into some speakers.

But ……  (you knew it was coming huh?)


Connectivity and companion processes failed me — in multiple ways.  My mobile warrior toolkit has been developed over a few years.  It includes such devices as power inverters, portable wireless routers, all the right charges and cables, etc.  I am used to having a few gotchas here and there, but usually have a backup solution to fall back on.  In some cases this weekend I had a backup, in some cases I did not, but was just frustrated with the myriad issues I had.  Here are a few:

  • Power Inverter issue – My daughter wanted to watch a DVD on a portable DVD player while driving in the car on the 8 hour drive.  My power inverter overheated after about 20 minutes and shuts down.  Oh well.  I went to Wal-Mart and bought another one.  It overheated after about 20 minutes and shut down.  Rated for 100 watts, pulling less than 50 and it overheats and shuts down.  Daughter gives up and sleeps instead.  Grr.
  • Belkin TuneBase – I love having my Zune in the car to have all my music collection with me.  I use a Belkin TuneBase to both charge and connect my Zune to my car’s speaker system.  Worked okay for the above, but it plugs in to the DC plug in the car and uses friction to hold it in place — NOT.  Every time I hit a big bump , then FLOP, it would bang over on the side, sometimes causing the Zune to fall out of the device.  I have tried all the inserts provided — same issue.  Solution = DUCT TAPE.   Grrr
  • When I arrived at my hotel (a Jamison Inn less than a year old), I was told there was only wireless in the lobby (can’t even pay for it in your room — ya gotta be kidding me).  I attempted to use the wireless in the lobby, but it would not DHCP me an address.  They did have a PC there hardwired, but who wants to use that thing?  It was so locked down, not even any WMP to listen to Eddie’s StreetDeck InkShow.  Grrrr.
  • So I pull out my Verizon activated OQO Model 02, and fired it up.  I was able to get a WWAN signal, but BARELY, and even when I did, it was so slow or dropped in and out so badly I gave up.  Grrrrr.
  • Okay — on to the next backup, my Verizon Aircard I use with my wife’s PC.  It worked pretty well in her computer (TC1100/XP), but barely worked in my X61 with Vista (which has to be a Vista driver issue).  Result = having to use a web client to get to my email.  Grrrrrr.
  • So I went to the party and fired up the X61 running pics on the projector.  I attached my Zune to my PC via USB to keep power there (I had not charged it fully since I was just going to have it there beside the X61), and discovered you cannot play your Zune while it is plugged in via USB.  I had not loaded my X61 with all the music I needed, my Zune partnership is with another machine at home.  Grrrrrr
  • I had planned a really cool “Collage” theme in Windows Vista Photo Gallery to use for my slideshow when I put the pictures together at home on my Gateway desktop.  I copied the pictures to the X61 before I left.  When I started my slideshow, I did not have that theme even listed on the X61.  Apparently those themes get disabled if you do not have a high enough Vista Experience score on your video card.  I had to use one of the boring and simple slideshows.  Grrrrrrrr

Grr, Grrr, Grrrr, Grrrrr, Grrrrrr, Grrrrrrr, Grrrrrrr.  It was the tech weekend from hell.

Did you notice my annoyance building?  I had just about every tech device I own and had planned to use fail me this past weekend in one way or another.  So this begs the question — Why do I keep trying to do this stuff?  Why so many problems? Am I being unrealistic in my expectations as a mobile computer user?  As I go about my workday, I have debugged most of the normal things that occur so do not notice that many issues, but when I enter into a new scenario and have this many problems, it seems to me the debugging process is nearly impossible to do beforehand.


If it can go wrong, it did this weekend.  Fortunately, it did not stop anything critical from happening.  What it did do was better help me to understand the non power user’s frustration with the current state of technology.  New devices arrive so fast, that they never really get a chance to get fully debugged, understood or implemented.  It is always about the newest and best device, and moving on to it.  I wont go into the full list, but some of my older equipment would have served me better than the current stuff.  It really stunk that my wife’s legacy TC1100 with Windows XP (a wonderful device btw) worked better this weekend than my brand spanking new X61 with Vista.


So how about you?  Do you get frustrated with nothing ever really working fully?  Do you settle for backups or give up functionality to keep the stress out of your life?  Am I the only one?

Technorati tags: ,