Vista SP1 Also Now Available for Lenovo X61

Rob has been reporting on his experiences with installing SP1 on the Dell Latitude XT Tablet PC most of the evening. Seems like things went relatively smooth. I’m now downloading the service pack on  the Lenovo ThinkPad X61 Tablet PC. It didn’t show under Windows Update initially, but after running the Lenovo Update software twice it did manage to show up. BTW I despise Lenovo’s software updater. It always seems to have to update itself before checking for new software. SP1 is taking awhile to download so I’ll report after the process is over in the morning.

Please remember, if you’re going to install SP1, make sure you backup and/or image your system. Just in case.


UPDATE 1: Download complete. But guess what? I get a Windows Activation message saying the system needs to be reactivated due to a change in hardware. I’m sure that has something to do with some of the Lenovo updates, although I don’t recall a BIOS update. But, I’ll just say this, (and it has been said many times before) updating Windows Vista and the hardware it runs on is like going to the dentist for multiple root canals. I think that should be printed on every sticker on every machine.

UPDATE 2: Things seem to have gone well. The install completed before I turned in for the night. I left things up and running over night knowing full well that Vista has some sorting out to do after an update like this. I can’t say I’m seeing any significant or noticeable improvements this morning, but there still seems to be quite a bit of things sorting out as evidenced by some continued disk thrashing this morning. More as it comes.

Technorati Tags: