Is Apple Blocking Google’s Chrome Browser on

mechrome Last month I made the change from an Exchange hosted service to Apple’s MobileMe / . So far, I’ve been pretty impressed with the services, the cost, and the reliability of the sync process. Apple has clearly made some headway since the disastrous launch last year.

However, all is not good in Google Chrome and land.


After getting Chrome installed on my loaner Vista-based Lenovo X200 Tablet PC and Windows XP-based HP Mini 1000, I hit up my account at, and what do I get — a blank screen.  No warning of a better experience with Firefox or Safari, no warning that Chrome is no longer supported, no message of pending problems. Nada. Nothing. Just a blank screen.

After a bit of research, it appears that Apple made some sort of change between December 15th and the 19th. Users on MacRumors forums, Apple forums, and Chrome forums are reporting the same problem; and, it doesn’t appear that a resolution is near at hand. What is odd about this particular problem is that both Apple’s Safari and Google’s Chrome are based on the same rendering engine: Webkit. In addition, many users have reported running blazingly fast using Chrome. A search in their help system revealed the following helpful results: Found 0 matches searching for chrome. Displaying matches 0 to 0.

Until Apple gets this problem fixed, and because Internet Explorer 7 isn’t fully supported, it appears that users will be stuck with Firefox or Safari to get access to their MobileMe data via  At the very least, Apple needs to issue a communication to their MobileMe customers regarding Chrome support and why it has suddenly stopped working.