Clicky

iOS 5.1 Jailbreak Already Available

By  |  4 Comments

Apple just launched iOS 5.1 and a lot of people installed it already, but jail breakers worried they would not be able to get the new update for some time.

Not so! It turns out the Dev Team already released an iOS 5.1 jailbreak using the Redsn0w jailbreak tool.

The Dev Team announced they cracked the new update the day Apple released it, probably because they worked on the beta version before the release.

The Redsn0w tool lets you run unofficial apps on your iPad, iPhone and iPod Touch among other unsupported practices. This jailbreak is only for the older iPhone 4, iPad 1 and iPod Touch.

If you have the iPhone 4S or the iPad 2, you cannot jailbreak iOS 5.1. This jailbreak will not work on the iPhone 4S, iPad 2 or on the new iPad, all of which use the new Apple A5 or A5X processor.

(Read: New iPad Jailbreak Will Take Time)

Dreamboard iPhone 4s jailbreak apps

The A5 processor protects the OS more efficiently. For that reason, jailbreaking it takes a lot longer and the iPhone 4S and iPad 2 both have the A5. The new iPad will come with an updated version of the processor called the A5X with quad-core graphics and Apple won’t likely turn off this security feature.

You will have to tether your device to run the jailbreak. A tethered jailbreak also requires you to hook it up to your computer when you restart your device in order to keep it jailbroken. If your iPhone or iPad restarts while it is not connected you will have limited functionality until you connect and restart.

You can get the Redsn0w 0.9.10b6 jailbreak at their website and jailbreak your iPhone, iPad or iPod on iOS 5.1. Let us know if you get it running on your older iPhone or original iPad.

Kevin loves notebooks, tablets, gadgets and photography. He grew up with computers starting out on a Vic 20 and Commodore 64. The first computer he owned himself was an 8086 Compaq Deskpro. His foray into tablet computing began when he bought a Samsung Q1 Ultra. The smartphone market opened up for him with his Palm Treo 600.

4 Comments

  1. devilla

    03/10/2012 at 5:41 pm

    I have Iphone 4s, but it says that it has software version 5.1 iOS.. ot doesn’t mention A5 so can I use the untethered jailbreak? 

    • Fuckunoob

      03/10/2012 at 9:57 pm

      Noob…fuck off

      • Jack C

        03/28/2012 at 11:54 am

        Everyone was a noob at a time…dont be so rude…

    • Yawlogic

      03/12/2012 at 3:24 am

      the 4s has the A5 processor so you cant jailbreak unless you are on 5.0 or 5.0.1.  And to “Fuckunoob” guy. Please correct people, not everyone knows it all. We are all here to lean on something.

  2. Cspoor08

    03/13/2012 at 4:28 pm

    i have the iphone 4 its on 5.1 when i try to use the redsnow one it allways says shsh blob error or need latest verson of redsnow and i have the newest redsnow please help me if u can help please email me cspoor08@gmail:disqus .com really would like help thanks 

Leave a Reply