Connect with us


New MacBook Pro Retina Problems: System Freezes, Unresponsive Keyboard and Mouse



The new 13-inch MacBook Pro late 2013 model with Intel Haswell processors are experiencing problems that can result in a system freezing and the keyboard and mouse becoming non responsive.

Owners of the 13-inch MacBook Pro Retina late 2013 models are sharing their complaints and issues on the Apple Support forum, and at this time it is not clear if the MacBook Pro Retina problem is tied to hardware or software.

This issue appears to affect various configurations of the 13-inch MacBook Pro Retina late 2013 models, including the base model with 4GB of RAM and the middle of the line model with 8GB of RAM and 256GB of storage.

The 13-inch MacBook Pro Retina late 2013 model with Haswell processors is freezing for some users.

The 13-inch MacBook Pro Retina late 2013 model with Haswell processors is freezing for some users.

13-inch MacBook Pro Retina late 2013 Freezing Problems

The Apple Support Forum entry for this issue is growing quickly, and is already at 18 pages of complaints from owners who are frustrated at the new MacBook Pro problems, especially the random freezing. The Apple console shows the following error for users who recover from this issue.

“The USB device Apple Internal Keyboard / Trackpad (Port 5 of Hub at 0x14000000) may have caused a wake by issuing a remote wakeup (2)”

If the new MacBook Pro freezes, the power button is still responsive to perform a forced reboot. Users shouldn’t lose any files, but this will cause them to lose any work that was in progress at the time.

The USB device Apple Internal Keyboard / Trackpad (Port 5 of Hub at 0x14000000) may have caused a wake by issuing a remote wakeup (2)

The USB device Apple Internal Keyboard / Trackpad (Port 5 of Hub at 0x14000000) may have caused a wake by issuing a remote wakeup (2)

Opening Console on the Mac and searching for “USB device” will show any of the error messages. In our testing the message is present over two dozen times, including once when we woke the computer from sleep to enter a password. We have yet to experience this bug on the $1,499 model sold in Apple Stores, even though the error is present.

How to Fix Haswell MacBook Pro Retina Freezing (Temporarily)

There is no official word form Apple on what to do, but one user suggests a temporary fix for the new MacBook Pro Retina freezing problem. This is not a fix for the root cause, so it can’t prevent the system from freezing again, but it should help users recover what they were working on. User epoxide on the Apple Support Forums offers the following solution,

“When mine freezes, just putting it into sleep for ~5 minutes seems to get the keyboard/trackpad working again.”

Multiple users report that this solution will work, though sometimes you must wait 10-15 minutes for the system to start working again. While less than ideal, it could help users avoid losing progress.

Users should also report this issue to Apple using the feedback section. With more reports Apple will be able to identify the issue better and recognize the scope of the problem. Fill out the feedback form here to alert Apple.

Various users report talking to Apple Support staff who offer varying solutions, including resetting the SMC (System Management Controller), though no one is claiming this is a complete fix. Here are the solutions offered to kyawlin, the creator of the post.

  1. Reset SMC Hardware test
  2. RUN Apple Hardware Test
  3. verify/repair disk (using disk utility)
  4. Final- Reinstall Clean OSX
  5. Wait for an release update software.

The issue appears to be present on all models of the 13-inch MacBook Pro Retina late 2013 update, as shown by a survey of users on this forum. The results skew towards the 256GB option, but that is likely due to it being the most popular choice.



  1. Jake

    10/28/2013 at 7:39 am

    I’ve had it hit my new 13″ 256GB 8GB model also purchased same day as yours Josh… :(

  2. Christopher Beatty

    10/28/2013 at 8:52 am

    My MBP arrives this week (finally – I had one of the custom configs). As a developer on Mavericks previews, I saw this several times for my MBA 2013. It was annoying when it happened, but never catastrophic. It also seemed to happen during transitory states,… battery reaching 100% and sleep/wake status changes. When I was constantly working and focused, it didn’t happen. I’ll be interested in seeing how this one unfolds.

    Great information on your site Josh, really appreciate your information share on the new MBPs!!

  3. Edin

    10/28/2013 at 2:04 pm

    Actually, this happend on my iMac (late 2012) waking up from screen saver, and all after Mavericks update.

  4. David Knight

    10/30/2013 at 3:35 am

    This has just happened to me on my late 2013 13″ MacBook Pro (2.8GHz i7, 8GB memory, 512GB SSD), so it’s the £1499 model with the £180 CPU upgrade.

    I had just alt tabbed back to Sublime Text and the keyboard and trackpad became unresponsive and failed to return after waiting several minutes so was forced to perform a hard reboot.

    I was using the laptop on battery at the time, half a dozen apps running, nothing intensive and around 45% battery remaining, just incase that has any relevance.

  5. Chris

    10/30/2013 at 9:30 am

    Same Problem here (13 inch, Late 2013).. Apple we need a software update here.. asap!

  6. colin

    10/31/2013 at 6:04 pm

    if you close the top down and wait about one minute then open it you will have control of the keyboard and trackpad again.

  7. simson

    02/15/2014 at 1:13 pm

    I have experienced the freeze many times.I have the USB device error in my messages log. However, the freeze actually seems to be associated with file system accesses. Specifically, any process that touches the file system locks up. I haven’t been able to diagnose it further.

  8. 313music

    03/11/2014 at 3:33 pm

    This issue affects my current production MBPR 13″, i7 2.8GHz, 16GB RAM, 512G SSD. The Boot ROM is the most current (MBP111.0138.B03). It certainly seems to be a Mavericks issue, but the latest 10.9.2 update did nothing to fix the continual kernel messages spewing in the logs

  9. Chad miller

    09/07/2015 at 10:21 pm

    I am having the same issue of freezing. The cursor seems to jitter and home screen swipes on… At least part way and then the whole Mac freezes. Command keys work but it’s a pain in the ass. I command save and command Tab and command Q everything. Then done a verity of reboots, Yosemite reinstall and still no progress. Cursor Works good at user password stage but freezes cursor wishing 5 min. Plugged in and not plugged in. Growing tired of it

  10. Spree-Liebe Hochzeitsfotografie

    12/26/2015 at 6:02 am

    I have the same issue. Freezing trackpad/keyboard. I have no freezes, when i plug in an external display. So i cant work mobile atm. I had the problem a year ago. The apple service couldnt help me with that problem. They tried to make a clean installation of OSX and it worked but i had this issue sporadic in the last year and now it happens again everytime i start my macbook. Most of the times when i click on my User Profile image to type in the password.

  11. I had the same issue and is one of the reasons I changed back to Windows!

Leave a Reply

Your email address will not be published.

As an Amazon Associate I earn from qualifying purchases.