Connect with us

Apple

5 Reasons Not to Install iOS 12.4 Beta & 3 Reasons You Should

Published

on

Don't Install iOS 12.4 Beta If You're Jailbroken

Don't Install iOS 12.4 Beta If You're Jailbroken

If you're currently using a jailbroken iPhone or iPad or if you're looking to jailbreak your device, avoid the iOS 12.4 beta for now. 

Jailbreak developers have released iOS 12 jailbreak tools, but we haven't seen anything for the iOS 12.4 beta and we'd be surprised if developers burned exploits on a beta.

If you want to jailbreak your iPhone or iPad you need to be on an older version of iOS 12, iOS 11, or iOS 10. Unfortunately, there's no way to downgrade to anything older than iOS 12.2.

For more on the iOS 12 jailbreak, take a look at our guide.

3 Comments

3 Comments

  1. Jim

    09/24/2018 at 4:44 pm

    I refuse to use web pages that spread out a single story over tons of pages. Like this one. It’s annoying as hell.

  2. judi ceme online

    10/15/2018 at 12:35 pm

    Please let me know if you’re looking for a article writer for
    your site. You have some really great articles and I feel I would be a good
    asset. If you ever want to take some of the load off, I’d absolutely love to write some material for your
    blog in exchange for a link back to mine.

    Please shoot me an email if interested. Many thanks!

  3. Jill

    03/25/2019 at 11:47 pm

    Same issue. Click bait to get through the article. I quit as soon as I saw the “2” with 9 pages total. It’s disrespectful.

Leave a Reply

Your email address will not be published. Required fields are marked *

This article may contain affiliate links. Click here for more details.